Dopo aver installato 'SQL Reporting Services 2008 R2 in integrated mode con SharePoint 2010 il tentativo di eseguire Report Builder dal menu new di una document library visualizza questo errore:
To use Report Builder, you must install .Net Framework 3.5 on this computer.

Install .Net 3.5
ma ovviamente sulla macchina avevo già il Framework 3.5.

Il problema sembra legato a un bug di Internet Explorer 9 su Windows 7 e 2008.

Un workaround per risolvere il problema è usare i developer tools di Internet Explorer richiamabile con il tasto F12 ed andare ad impoststare in Browser mode il valore Internet Explorer 8, l'applicazione click once Report Builder viene scaricata e installata... con continue martellate tutto magicamente funziona.

Da un ultima prova fatta sembra che il problema sia risolvibile semplicemente aggiungendo la url del sito nella zona Local intranet (nel menu Internet options scheda Security).
Rettifico la zona sembra ininfluente al fine del funzionamento di Report Builder.
Quindi ricapitolando in Brouser mode: IE9, che è il default, non funziona mentre in Browser mode: IE8 o Browser mode: IE9 Compatibility View funziona.

Se poi dovesse comparire l'errore
Cannot retrieve application. Authentication error.
bisogna andare nel pannelllo di controllo in Credential Manager (Control Panel\User Accounts and Family Safety\Credential Manager) ed aggiungere manualmente le credenziali impostando url del sito, dominio, utente e password. Inserire anche il sito nella zona Local intranet per garantire il passaggio delle credenziali.