SharePoint 2010 dopo una migrazione da 2007 mi segnala il seguente errore nell'Health Analyzer:
[MissingSetupFile] File [1033\MPS\..\sts\lists\wplib\dwp\MSContentEditor.dwp] is referenced [2] times in the database [SP2010Dev_Content], but is not installed on the current farm. Please install any feature/solution which contains this file. One or more setup files are referenced in the database [SP2010Dev_Content], but are not installed on the current farm. Please install any feature or solution which contains these files.
In pratica mi dice che un file è referenziato nel db ma non esiste su file system, ma soprattutto non mi dice quale sito referenzia questo file.
Per trovarlo è sufficiente eseguire la seguente query sul DB di content segnalato:
C#
SELECT DirName, LeafName, SetupPath, SetupPathUser
from SP2010Dev_Content..AllDocs
where SetupPath='1033\MPS\..\sts\lists\wplib\dwp\MSContentEditor.dwp'
ritorna un risultato di questo tipo
DirName                             LeafNAme            SetupPath                                           SetupPathUser
sites/forumRisUm/_catalogs/wp	    MSContentEditor.dwp	1033\MPS\..\sts\lists\wplib\dwp\MSContentEditor.dwp	MIP\kmsadmin
sites/forumSupplyChain/_catalogs/wp	MSContentEditor.dwp	1033\MPS\..\sts\lists\wplib\dwp\MSContentEditor.dwp	MIP\kmsadmin
Dopo aver cancellato il file mancante da SharePoint (in alcuni casi usando il Designer) e essersi assicurati di non avere riferimenti nel cestino, alla successiva scansione dell'Health Analyzer la segnalazione viene rimossa.
Potrebbe interessarti anche: