Mi è capitato di recente di avere problemi di lentezza con Internet Explorer 10, la cosa strana era che con Firefox tutto funzionava normalmente, quindi non sembrava un problema legato al PC ma a IE.
Ogni volta che richimavo un sito nuovo rimaneva a lungo in attesa e la barra di stato visualizzava Waiting for response ..., rimaneva così per molti secondi prima di visualizzare la pagina.

A questo punto ho provato l'utility SFC.EXE:
SFC.EXE /SCANNOW
che mi segnalava alcuni file corrotti ma non riusciva a riparali (il log si trova in C:\Windows\Logs\CBS\CBS.log).

Poi ho provato l'utility DISM.EXE:
DISM.EXE /Online /Cleanup-Image /RestoreHealth
ma anche qui segnalava degli errori, ma non riusciva a fissarli (il log si trova in C:\Windows\Logs\DISM\dism.log).

Infine ho provato ad andare in Control Panel > Find and fix problem > Fix problem with windows update dopo aver finito, ha chiesto di essere rieseguito con elevati privilegi ed ha trovato due errori che è riuscito a sistemare con successo. Dopo questo Internet Explorer andava benissimo.

Dopo questo intervento si è risolto un altro problema che avevo con del codice in C# che si connetteva a SharePoint 2013 Online tramite il Client Object Model. Ogni volta che cercavo di connettermi tramite questo codice:
ClientContext ctx = new ClientContext(url);
System.Security.SecureString secpwd = new System.Security.SecureString();
for (int i = 0; i < pwd.Length; i++)
  secpwd.AppendChar(pwd[i]);

SharePointOnlineCredentials creds = new SharePointOnlineCredentials(user, secpwd);
appena arrivava al'ultima linea per validare le credenziali, rimaneva in attesa per parecchi secondi e poi ritornave questo errore:
{"Identity Client Runtime Library (IDCRL) could not look up the realm information for a federated sign-in."}
Risolto il problema con Internet Explorer si è risolto anche questo, infatti su altri PC funzionava correttamente.